Discussion:
Contribution to coreboot board status
(too old to reply)
Sven Dreyer
2018-10-23 08:16:57 UTC
Permalink
Hi list,

I'd like to contribute the board status of my Alix 2C board, which runs
great using coreboot. https://coreboot.org/status/board-status.html says
that this is possible if you have an account at review.coreboot.org, but
on that site, there is no "create account" button. Login with launchpad
credentials works for the website, but when I run "./board_status.sh
-u", remote git (of course) doesn't accept my launchpad credentials.

Is there any possibility to get an account for that site? Alternatively,
I could send a tarball with the files collected by board_status.sh

Thanks and best regards,
Sven
--
coreboot mailing list: ***@coreboot.org
https://mail.coreboot.org/mailman/listinfo/coreboot
Sven Dreyer
2018-10-24 08:31:55 UTC
Permalink
Hi Patrick, hi list,
After you're logged in with Gerrit, you can get git-compatible
credentials at https://review.coreboot.org/settings/#HTTPCredentials
that you can then store in $HOME/.netrc for git to pick up.
Thanks for the hint. I have no experience with gerrit, so this wasn't
self-explanatory to me.

With the http credentials, I was able to submit my results. At least I
think so, because I had to enter the credentials and didn't see any
error message when I tried it yesterday. But
https://coreboot.org/status/board-status.html still shows a date from
january for the alix2d platform.

Repeating the process today because I thought I did something wrong
results in "Result is a duplicate, aborting", which makes me think
yesterday's commit was successful:

$ util/board_status/board_status.sh -r 192.168.100.22 -u
Extracting config.txt from build/coreboot.rom
Extracting payload_config from build/coreboot.rom
Temporarily placing output in
/tmp/coreboot_board_status.z2kpCZw9/pcengines/alix2d/4.8-1857-g076ce2f4d9/2018-10-19T09_25_23Z
Verifying that CBMEM is available on remote device
Getting coreboot boot log
Getting timestamp data
Failed to run "cbmem -t", ignoring
Getting remote dmesg
Cloning into 'board-status'...
remote: Counting objects: 65707, done
remote: Finding sources: 100% (28/28)
remote: Total 105407 (delta 3), reused 105404 (delta 3)
Receiving objects: 100% (105407/105407), 214.71 MiB | 652.00 KiB/s, done.
Resolving deltas: 100% (27205/27205), done.
Checking out files: 100% (70725/70725), done.
Checking for duplicate results
Already up-to-date.
Result is a duplicate, aborting

One more thing: My board is an Alix 2C, which is pretty similar to the
Alix 2D. It is reported as "alix2d", so the table at
https://coreboot.org/status/board-status.html will always show "unknown"
as status for the alix2c, which might be confusing.

Thanks and best regards,
Sven
--
coreboot mailing list: ***@coreboot.org
https://mail.coreboot.org/mailman/listinfo/coreboot
Loading...